Universal/Westerbeke info

  • February 02, 2016 4:29 PM
    Message # 3796972

    If anyone is powered by a Universal/Westerbeke engine I have some info regarding a common problem with the Sherwood raw water pump that (IMO) is very important. 

    I won't bother posting the info if no one has a Universal/Westerbeke with a Sherwood pump. But if you have one you need to know what I just experienced and the "easy" solution(s) to prevent an inevitable pump failure.

  • February 04, 2016 8:52 AM
    Reply # 3800959 on 3796972
    Deleted user

    Mike I have an old 4-107 with I think a shurwood pump (will have to look) but I am interested in what you found, or if at risk for? (leak?) 

    Thanks:

    Norm 

    Last modified: February 04, 2016 11:20 AM | Deleted user
  • February 26, 2016 6:09 AM
    Reply # 3845796 on 3796972

    Mike,

    I have a Universal M50 B that I just replaced my Sherwood raw water pump in. What important info do you have that will save me future problems?

    Cheers,

    Will 


  • February 26, 2016 12:43 PM
    Reply # 3846530 on 3796972

    I have an M-50 and I would like to know what will save me time and $$$$ on the rew water pump.

  • February 27, 2016 9:07 AM
    Reply # 3848074 on 3796972

    For any Sherwood or Jabsco impeller pump, you should get a Speed Seal setup to replace the standard end plate and impeller.   I had a long time diesel mechanic give a talk at a rendezvous a few years ago, and he said one of the most frequent service calls he had was with overheating due to the sea water pump.   He started using the Speed Seal kits on the pumps, and has never had a problem with them since.  www.speedseal.com.

    PBO Review 2015

    Last modified: February 28, 2016 11:34 AM | Anonymous member (Administrator)
Powered by Wild Apricot Membership Software